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Developer Introduction 

Best Practice

Best practice Flash Development requires the following resources to exist as Subversion repositores available to all Flash Developers…

· Current Eclipse environment

· Current ‘Core Flash Classes’

· Current Actionscript code library

· Current MTASC Actionscript compiler

Additionally, if all Flash Developers make use of a standard Eclipse Workspace location then ANT scripts can be easily transferred and used on different workstations without alteration.

Install Development Software

Download the Tortoise SVN Client Version 1.3.5 from http://tortoisesvn.net/downloads and run the installer. 

Open 'My Computer', then open 'C:' 

Right-click in the C: window and select 'Tortoise SVN/Export...' - Enter the URL of your Eclipse repository – eg 'http://subversion.chrisfoster.com.au/repo/FlashDevEclipse3.2Install' in the dialog box and click 'OK', then wait for the checkout process to complete. 

While the checkout process runs, create a directory on C: called '_workspace'. 

When the checkout has completed, open the C:eclipse directory and double-click 'eclipse.exe' to run Eclipse for the first time. When the dialog box asks for the default workspace location choose 'C:_workspace'. 

REQUIRED RESOURCES

Choose 'Window/Open Perspective/Other' and select 'SVN Repository Exploring'. Then Right click in the opened panel and choose 'New/Repository Location'. Enter the URL of your code library repository – eg, http://subversion.chrisfoster.com.au/repo/FLASH_CODE_AS2 and click 'Finish'.

When the repository location has appeared in the 'SVN Repository' panel, right-click it and select 'Checkout', then choose 'Check out as a project in the workspace' in the dialog box. You've just connected to/checked out the first of 3 required repositories for Flash developers. 

Now check out (as projects in the workspace) the following repositories...
http://subversion.chrisfoster.com.au/repo/mtasc http://subversion.chrisfoster.com.au/repo/COREFLASHCLASSES 

FDT SETUP

In Eclipse choose 'Window/Preferences' and click on the '+' next to FDT to open the FDT preference tree. 

Click 'Core Libraries', then 'Add' and add 'C:\_workspace\COREFLASHCLASSES\Flash7' and 'C:\_workspace\COREFLASHCLASSES\Flash8'. Click the checkbox next to the Flash8 library to mark it as your default. 

Now click the '+' next to 'Tools', then click 'MTASC' an enter 'c:\_workspace\mtasc\mtasc.exe ' into the dialog box. 

Finally, open the 'Code Style' tree, click 'Code Templates' and the 'Import'. Navigate to 'C:_workspace/FLASH_CODE_AS2/FDT Templates', select 'templates.xml' and click 'Open'. Now close the 'Preferences' dialog and you're done! :) 

Checkout Subversion Repositories

Once your plugins and tools are installed, switch perspective to Flash. Open the Eclipse SVN Repository view and add new repository locations from the URL's below. Then checkout each URL as a project in your Eclipse workspace, using the project name provided with each URL. (Right click the repository location once added, and select Checkout...) 

· repository URL: http://subversion.chrisfoster.com.au/repo/COREFLASHCLASSES 

· Project name: COREFLASHCLASSES 

· repository URL: http://subversion.chrisfoster.com.au/repo/FLASH_CODE_AS2 

· Project name: FLASH_CODE_AS2 

· repository URL: http://subversion.chrisfoster.com.au/repo/mtasc 

· Project name: mtasc 

Resuming a failed svn checkout

If the checkout SVN process fails and a project folder has been created in the Flash Explorer, right click and select Team > Update. If this option is not available, try using Team > Share Project to reconnect to the repository, and then select Team > Update. If this fails too, alert the Flash Team Leader who will be able to assist you. 

Configure Eclipse Plugins

Subclipse

Configure Subclipse

Eclipse integrates into the Subversion server via Subclipse. 

The base URL for all repositories is at... 

· http://subversion.chrisfoster.com.au/repo 

When you checkout a project to your Eclipse workspace, check with your tech lead or the Flash Team leader to determine which branch you are working from. 

Ideally each project will contain at least one trunk, tags and branches folder. These are used to split development when different parts of an application need to be worked on which may affect other parts. 

Design assets and other media should be kept out of repositories, or kept in separate module folders (each containing a trunk, tags and branches folder) 

Important Note

The Subclipse environment can be unforgiving and can, if initial user errors occur, become severly disabled. When you delete items from your working copy in Eclipse, these items will be marked as deleted in the repository. Delete items CANNOT be recovered. If you need to delete something from the working copy, so that you can restore the latest version from the repository, do the operation in Windows explorer. 

When you copy files in a repository be equally careful. Hidden .svn folders are present which maintain meta-links to the repository. If copied with files or folders they will maintain incorrect links to the repository. Always copy files and not folders. 

If you need to copy a lot of files take care not to replicate any .svn folders. 

ANT will enable you to copy files and will filter out all versioning files (including VSS and CVS) so this is a prefered way to copy large groups of files, especially in the case of deployment to servers or to distribution archives. 

· see http://en.wikipedia.org/wiki/Apache_Ant 

FDT

To configure FDT's settings select Window > Preferences... > and select FDT. You need to set the core flash classes, MTASC and code templates. 

Core Flash Classes

The repository you checked out COREFLASHCLASSES contains a maintained set of Flash intrinsic classes and the MX class library, including the Flash remoting library. This is used as the standard class library for Eclipse FDT syntax highlighting. 

In FDT preferences, select Core Libraries and Add... the following paths. 

c:\_workspace\COREFLASHCLASSES\Flash8

c:\_workspace\COREFLASHCLASSES\Flash7

Name them Flash8 and Flash7 respectively. Mark Flash8 as the default. Remove any other Core Libraries if they exist. 

MTASC

In FDT preferences, select Tools > MTASC. 

Set the Location of mtasc.exe to 

c:\_workspace\mtasc\mtasc.exe

Code Templates

FDT Templates

The Flash Team are creating Code templates to help build readable and easy to use code structures and fragments, here's the current list of available custom templates. Each one provides the preferred implementation of it's code structure. These are supplied in addition to the FDT default templates. 

	Description 
	template name 

	Member variable 
	mvar 

	Create delegate 
	createdelegate 

	Add event listener 
	addeventlistener 

	For in loop 
	forinloop 

	For loop 
	forloop 

	Create singleton 
	singleton 


You will find the current FDT templates in c:\_workspace\FLASH_CODE_AS2\FDT_Templates\templates.xml 

Use Menu: Window > Preferences > FDT > Editor > Templates > Import... to import them into FDT. 

Templates are used in code by typing the template name (or a portion of it) and pressing Ctrl+Space 

Templates to do list

	Description 
	template name 

	Method 
	method


Mylar

Mylar integrates Trac into Eclipse... 

Projects should always have an associated Trac repository, this is used to collaborate on documentation and track bugs, tasks and enhancements. 

Viewing the Mylar task list

With Mylar installed in Eclipse the menu, Window>Show View>Task List will display the Mylar Task List view. 

Adding a trac query to the Task List

· Right click the context menu on the Task List view. Select New>Query... 

· The New Query window will open, click Add Task Repository 

· Select Trac from the list 

· Fill in the Trac URL, a suitable label, your Endemol login details, then select Validate Settings 

· Once a task repository is added you can select it and create a new query 

· For example you can create a query of tasks or bugs assigned to you. 

Working with Mylar Tasks

You will generaly be working with Repository Tasks in Mylar, these are stored in Trac and will be visible through the Task List via a Query. 

Adding a Repository Task

· To create a new Repository Task click [image: image1.jpg]


button. 

· This will open the Task Repository Selection window. 

· Select the repository where you want to add a Task. 

· The information screen above will display, reminding you that queries will need to be synchronised to see new tasks. 

· Fill in the information for the Task (etc) in the Trac browser window displayed. 

Working on a Repository Task

When you are working on a task you should select it when you are working on it, and deselect it when you have finished working with it. Mylar will keep a track of your working schedule so you can see how much time you have spent on a task. This is very useful when providing estimates in the future so try and maintain your active task status. 

Additionally Mylar will link open resources to the active task. This means that when you activate a task the resources, code, etc. you were working on with that task, will be opened when you reactivate it. 

You can clear the resources linked to a task (if there are any) by right clicking a it and and selecting Clear Context... 

Flash Debug Environment

The flash debug player will allow you to trace output from a browser or standalone player to a text file. This is far more preferable than ANY other method of gathering debug info from Flash in a browser. Other methods such as LocalConnection, XMLSocket or floating TextFields are only to be used if for some reason your system fails to work with the Flash Debug player. In such an event the Console class in the FLASH_CODE_AS2 library should be used, this is a simple TextField console, which many of our Flash applications already use. 

FlashTracer

The FlashTracer plugin for FireFox will display output for you in a text window, when installed it will also configure the output file for you. 

Eclipse log viewing

There are a few log file viewers available for Eclipse, unfortunately none of them offer an eclipse update site. Installation must be done manually (unzip the plugin into c:\eclipse\plugins) I'm not amazed by any of them (there are issues with each one.) 

Here they are if you would like to check them out... 

· Ntail - http://www.certiv.net/products/ntail.html 

· Logfile Viewer - http://sourceforge.net/projects/logfiletools 

· Log Watcher - http://graysky.sourceforge.net/ 

A new one I haven't tried out... 

· Logviewer - http://www.mikenimer.com/index.cfm?mode=entry&entry=03B7193D-4E22-1671-5C1199EC6DA5124E 

mm.cfg

Providing a mm.cfg file can be found in your %HOMEDRIVE% and %HOMEPATH% locations. To see what %HOMEDRIVE% and %HOMEPATH% are set to, run cmd, and at the prompt enter set. The list displayed you'll see HOMEDRIVE and HOMEPATH, these should be set to U: and \ respectively. If they are copy the mm.cfg generated by FlashTracer (which should be found in C:\Documents and Settings\user.name\) into U:\ and providing everything is working properly all trace output from Flash will appear in the FlashTracer window. 

Flash Player 9.0r28

As of this version of the Flash Player the debug log is output to %USERPROFILE%\Application Data\Macromedia\Flash Player\Logs\flashlog.txt and mm.cfg no longer affects the output filename or path. 

Trace messages

Your trace output messages should prefix with either... 

· DEBUG: 

· INFO: 

· WARN: 

· ERROR: 

· FATAL: 

These allow you to communicate the severity of the message, and also provide a standard filtering method. Please remember, non-essential traces should be removed as appropriate, ie. before you commit code to a repository. 

Using trace messages such as "doing stuff" or "####### >>>> over here", is just plain dumb, don't do it. 

Flash Development Checklist

Before the commencement of development work, please ensure the following are available. Also ensure that each item has been checked and is satisfactory.

	Item
	Source
	

	Project Code
	Project Manager
	

	SVN repository
	Tech Lead / Flash Lead
	

	Trac
	Tech Lead / Flash Lead
	

	Technical Spec
	Project Manager
	

	Wireframe
	Producer
	

	Verbal Brief
	Producer
	

	Target Platform
	Tech Spec
	

	Accessibility requirement
	Tech Spec
	

	Assets, Fonts, etc
	Producer
	

	Preloading Strategy
	Producer / Tech Spec
	

	Preloading Assets
	Producer
	

	Coded animation descriptions
	Producer / Wireframes
	

	Estimated time
	Project Manager / Developer
	


Signed (Flash Developer)
Date
/
/

Signed (Flash Team Lead)
Date
/
/

Flash Coding Standards

Flash coding standards demonstrate a commitment to producing solid application design, with clean, maintainable and clearly documented code, adhering to best practices. This is an evolutionary process and will be improved upon wherever necessary. 

Below are a series of articles which outline our coding standards... 

ActionScript Code Formatting

There are several code formatting conventions…. 

· Code Bracing 

When using if else the following bracing should be used. 

if(condition) {

    // condition is true

} else {

    // condition is false

}

When using for function or do while the following format should be used. 

for(var i=0; i<len; i++) {

    // always refactor loop code to a private method

    myLoopCode(myArray[i]);

}

When using switch case the following format should be used. (note: it should be suggested that the use of switch case is not a good OOP practice.) 

switch(mySwitch) {

    case 1: {

        myCaseOneHandler();

        break;

    }

    case 2: {

        myCaseTwoHandler();

        break;

    }

    default: {

        myDefaultCaseHandler();

        break;

    }

}

· Indenting 

Standard tab based indenting should be used, each closing block should align to the opening statement of the block eg. 

if (condition) {

    if(subCondition) {

        // 

    } else {

        // 

        if (miscCondition) {

            // 

        } else {

            // 

        } // -- if miscCondition close

    } // -- if subCondition close

} // -- if condition close

· Whitespace 

Operators should have a space between them and the other parts of their expressions e.g. 

var i:Number = 0;

i += 10;

var modulo:Number = i % 2;

Opening braces should have a space before them and a newline after them, closing braces should have a newline before and after them, as shown in the example above. 

Class properties (fields), parameters, return types, local variables and their types should not be spaced, for example 

var myVarName:String;

· Object paths 

Object paths which extend over a comfortable reading width (approx 40 chars) it is advisable to split and indent the call with each dividing period at the beginning of each line, for example. 

   var myValue = getTopScope()

                     .getSecondScope()

                     .getThirdScope()

                     .myThirdScopeValue;

or 

    var myValue = myRootObject

                      .mySecondLevelObject

                      .myThirdLevelObject

                      .myThirdLevelValue;

· Function arguments 

Function arguments which extend over a comfortable reading width (approx 40 chars) should be split of multiple lines, for example. 

private function myMethodSignature(param1:String, param2:Number,

                     param3:Array, param4:Point, param5:Number):String {

    // method code ...

}

· Conditions 

Conditions which extend over a comfortable reading width (approx 40 chars) should be split of multiple lines, for example. 

if(condition1 ||

   condition2 &&

   condition3) {

   // condition evaluated to true...

}

· Array assignment 

Long array assignments which extend over a comfortable reading width (approx 40 chars) should be split of multiple lines, for example. 

var myArray:Array = [

                     value1,

                     value2,

                     value3,

                     value4,

                     value5,

                     value6,

                     value7,

                    ];

· Other long assignments 

As you can probably tell anything which would otherwise extend over a comfortable reading width (approx 40 chars) should be split of multiple lines, for example. 

var customType:CustomType = new CustomType(

                         new CustomEvent(CustomEvents.ONEVENT), 

                         new CustomDataItem("Mr Smith", 32)

                       );

Naming conventions

Introduction

Choosing a good name for a class, method or variable is a problem common to all programming languages. A good name is a subjective thing and will often depend on the project and the programming language. Through increased use of the language, conventions are established and informally agreed upon. 

The conventions presented here are not cast in stone, however, other ActionScript programmers will find it easier to read, understand and reuse code if it follows guidelines such as these. 

General Naming

Choose names that clarify purpose. Since ActionScript allows identifiers to be of any length; all characters are significant. Long names are important but may be limited by conventions of readability. 

Descriptive names require fewer explanatory comments, Unique pronunciation for names simplifies human communication and avoids confusion. The following name qualities are helpful in understanding code. 



Guideline 1

Choose names that are descriptive. 

Example

· dateOfBirth - good. 

· dob - bad. 

· milliseconds - good. 

· ms - bad. 

· menuBar - good. 

· mBar - bad. 



Guideline 2

Choose names that have a unique pronunciation. 

Example

· readSize - bad. 

· sizeToRead - good. 

· sizeJustRead - good. 



Guideline 3

Begin Class and Interface names with an uppercase letter. If a compound word is used, each word should begin with an uppercase letter, ie. CamelCase. In the case of Interfaces the first letter of the name should always be capital I. 

Example

· DisplayManager - good class name. 

· IEventDispatcher - good interface name. 



Guideline 4

Begin instance, variable, method and parameter names with a lowercase letter. Again, if a compound word is used, begin each word following the first word with an uppercase letter, ie. camelCase. 

Example

· address - good. 

· timeStamp - good. 

· readyNow - good. 

· readynow - bad. 



Guideline 5

Constants and event names should be in all uppercase. Event names should also always be preceeded by ON, and should clearly describe the event being dispatched. 

Example

· VERSION - good constant name. 

· version - bad constant name. 

· ONDISPLAYUPDATE - good event name. 

· COMPLETE - bad event name. 



Guideline 6

Choose class names which are indicative of a classification of objects. Select the least restrictive name possible for a reusable class. 

Example

· ErrorReport - good. 

· Application - too generic. 

· TreeWalker - good. 

· TreeWalkerForBinaryTrees - too specific. 



Guideline 7

Choose interface names which are indicative of a set of behaviours of objects. Again, select the least restrictive name possible. 

Example

· IDispatcher 

· IEvent 

· IDisplay 

· ITree 

Programming to interfaces allows you to keep your code as flexible as possible, whilst retaining strict typing of variables, parameters and properties. 



Guideline 8

Type suffixes (or reverse hungarian notation) e.g. _mc are no longer particularly helpful within your code. When using Eclipse a rollover will reveal the type of any property, interface, class, var, method or parameter. If this style of naming has become a habit for you, it is tolerable, although strongly discouraged. 

Example

· canvas_mc - bad. 

· canvas - good. 



Gudideline 9

Prefixes to denote class properties are not used. 

Example

· tweeningSequence - good. 

· mTweeningSequence - bad. 



Guideline 10

Prefixes to denote method parameters are not used, if the parameter value is being passed to a class property the method should use the explicit this prefix to denote the class property, when the value is assigned. There is an exception to this rule, when using setters to assign a value to a property the standard name value should be used as the assigning parameter (note: to provide true encapsulation, your class properties should always be private). 

Example

class Person {

    private var _age:Number;

    public function get age():Number {

        return _age;

    }

    public function set age(value:Number):Void {

        // Note: value is used in setter methods

        _age = value;

    }

    public function Person(age:Number){

        // Note: age in this scope refers to the parameter value, 

        // this.age refers to the class member.

        this.age = age;

    }

}



Guideline 11

Ideally choose method signatures that someone reading will understand as if it were a sentence. 

Example

public function move(pointA:Point, pointB:Point, duration:Time, easing:IEasing):Void {

    // method code...

}



Guideline 12

When there is an accepted short name for a value it's use is acceptable, however this should only be used for the following. 

· i - used as a for loop iterator 

· len - used as a for loop length identifier 

· x, y, z - always used as a coordinate value 

· a - used as a string iterator in a for in loop 

If you would like to use a short name not listed here, it is more likely that a long form is preferred, for example 

· temperature not t 

· degrees not d 

· rotation not r 

Eclipse makes it easy to reuse long names and it seem that in AS3.0 long names no longer present the performance issues found in AS2.0. 

It should be pointed out that this guideline is the loosest of all presented here, the preference toward longer names should be taken as the guideline here, practicality should take precedence over regulation. In any case short names used must have an explicit meaning and there should be no ambiguity of purpose. If developers use conventions such as sec to denote seconds, this is acceptable although not encouraged. The use of naming such as v1, v2, v3 or b, c ... j, k (etc, etc) however, is not acceptable. 

Refactoring

What is refactoring?

Refactoring is the process of restructuring code for the purpose of readability, performance improvements, reuse, or simply for the regular evolutionary quest for elegance. 

Sadly one of the main omissions from FDT's tool set is the automated refactoring features of the Eclipse Java development environment, and so, refactoring must be done by hand. 

Why refactor?

Refactoring is done for two main reasons, (1) to improve code structure generally for readability and maintenance and (2) to de-couple code for reuse. There is a third reason, the pursuit of graceful solutions to coding problems, although this is a little more esoteric, it is still a good reason to refactor. 

How is refactoring done

One word, carefully or perhaps two words... very carefully. In the case of common libraries this should be taken extremely seriously. Even when you have made sure that a refactored method or class provides the same functionality through a different implementation, please be aware that certain things are just a little bit odd in Flash and ActionScript. If you want to refactor an existing part of a common codebase, please do not commit the refactored version without emailing all other developers  and when you do commit, provide a meaningful explanation of the refactoring done and the reasoning behind it. 

Refactoring scenarios

There are a number of common code scenarios for refactoring, they range from simple changes to naming conventions (which are often precarious to enact without automation). To more intricate situations which require careful analysis before any decision can be made to implement. 

This list of coding guidelines offers other some possible refactoring scenarios:

Standard practices

The following is a set of coding guidelines. To add or modify guidelines to this list discuss and review them with the Flash Team Leader.

· nested behavior 

A loop or condition should, in many cases, call a method to do it's work. This will usually achieve at least one of two goals; (1) simplifying maintenance; (2) decoupling nested code. Generally speaking this guideline should be applied pragmatically, if you can see that repetition of code is likely, then there would be an obvious case to refactor the nested behavior to a method. Alternatively if there is a complex piece of code within a loop or condition it will often be useful to refactor out to a method to simplify code maintenance, it's future reuse will be simplified too. 

A loop or condition which is nested within a parent condition is acceptable at a single level of nesting, as is recursion, however it should be carefully implemented. Further levels of nesting are usually either due to overlooking a recursion case (and limiting further flexibility), or are overly complex for the job. In most cases refactoring the nested loops or conditions out to a series of methods will reveal the logical integrity of the code. For example, if you are manipulating a fixed tree or model structure and using a hardcoded method to walk the tree it will often be advisable to reconsider the implementation and use recursion. Discuss this guideline with the Flash Team Leader if you need further help in seeing the advantages. 

· Patterns 

In ActionScript there is certainly a large degree of legacy code, coding styles which are not adherent to the current standards, callback functions, Object listeners and the like are obsolete, and have been superceeded by the use of the EventDispatcher (Observer pattern). Equally the _global scope is also no longer considered acceptable, and a Singleton pattern would now be used instead. As pattern based implementations are finding their way into ActionScript it is best to refactor older implementations of functionality using standardised, decoupled pattern based implementations. 

· Scoping 

In ActionScript 2.0 there is a simple scoping problem which most advanced flash developers are familiar with, this is of local scope overriding class scope, this is particularly significant when using callbacks, but also when using the EventDisptacher pattern. 

Example 

If we have a class MyClass which dispatches an event ONREADY our observing class would have to register interest in this message using addEventListener as we see below. 

myClass.addEventListener(myClass.ONREADY, readyHandler);

This example would use the observing class's method readyHandler to deal with the event, however, when called it would loose scope from the observing class and would therefore loose access to the observers private methods. 

To deal with this there is the Delegate class which allows the handler to be registered with the subject class (MyClass) and retain the observers scope, so the example above would be coded as... 

myClass.addEventListener(myClass.ONREADY, Delegate.create(this, readyHandler));

This problem has often been solved with using the following method or similar, it should be stated that nested functions are the work of the devil, root them out. 

private function myMethod():Void {

    var _instance = this; // often alternatives are _self, _this, inst, instance, etc...

    myCallback = function() {

         _instance.myPrivateMethod();

    }

}

· MovieClip Scope 

One of the most common coding instances which presents itself for refactoring is the use of direct timeline MovieClip scope. Any class contains a direct refence to a timeline address (ie. _root) should have that reference passed via a setter or through the class constructor. 

· Magic Numbers and Magic Strings 

The compiler will help us to catch many errors at compile time, syntax and type checking are very helpful ways of reducing runtime errors, it is also important that string and numeric values are given names so that they can be easily identified during maintenance and code review. The application scope of a magic string or number will determine it's definition, often they should be defined as class properties or local variables. 

In any case, using a magic string or magic number should be deprecated in favour of a variable, this way no typo's or other syntactic errors can creep into your code via these values. 

· MovieClip subclasses 

Wherever possible it is preferable to composite MovieClips into a behavioral class as opposed to creating a MovieClip subclass. Additionally the Symbol Library facility to add class linkage to MovieClip symbols should not be used, as it can be difficult to manage. For example no trace of the linkage exists outside of the Library, and this makes tracking linkages difficult, especially when no other documentation of the linkage exists. 

Classes and Interfaces

Classes and Interfaces provide you with code data types. Don't use classes as arbitrary containers of procedural code, try and break your code up into the objects which comprise the system, as opposed to creating a functional decomposition of a system and using a class to hold all the functions for that process. 

This topic can be discussed at length, but it is important that you observe OOP principles of Composition, Inheritance, Encapsulation and Polymorphism... 

A brief discussion on Interfaces

Interfaces are often misunderstood, so I am providing a quick note here to make sure that the main features of interfaces are clearly understood by all developers here at Endemol Interactive. 

Interfaces are (in use) primarily data types which are defined by a set of abstract behaviors, the actual code of these behavior methods are provided by classes which implement them. 

So within an Interface... 

· Behaviors are defined as public method signatures. (Note: Private methods cannot be defined in an interface.) 

When a class implements an interface it must implement the methods from the interface, the compiler will fail if this is not the case, and so Interfaces serve the purpose of creating a coding contract for a class to adhere to. 

In addition, Interfaces should be used to provide flexible data typing on a set of classes which implement them. That is to say, a group of classes will share a set of behaviors so that a method parameter, class property, local variable or return type can be specified as an interface. Code which is handling an object in such a way can manipulate the object's methods which are defined in that interface. 

This technique is known as programming to interfaces, and is generally the most elegant way to implement Polymorphism within your application. 

Within ActionScript 2.0 Interfaces only allow you to define public methods, no properties or getter / setter methods may be defined. Private members may not be defined in an Interface. 

Bibliography
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Documentation and Code Comments

The use of JavaDoc style code comments is approved within ActionScript source. Doxygen (along with Eclox for Eclipse integration) is used to generate HTML documentation. 

Documentation policy

Documenting your code as you write it is important, the best strategy is to keep your descriptions terse and clean until methods and classes mature. The point at which you are making the finishing touches to a class or method, is the best time to do the final commenting. If you are simply staring at a blank line with no previous comments you are unlikely to start them, and to be honest, this isn't uncommon. 

So make sure you add a little to your code commenting as you make changes, but don't bulk them down in too much detail (e.g. lots of examples and caveats) until they are practically finished. With the same token, always make sure there is some form of explanation of a class or method, even if you have seen this lacking in other project code. 

Encourage others to document code too, it's an important part of your job. 

Doxygen in JavaDoc mode

For a full run down of JavaDoc and Doxygen support for ActionScript see Doxygen guide and JavaDoc guide 

You'll probably notice in the Doxygen guide the use of \param as opposed to @param is a common format, since ActionScript is more similar to Java than C++ use the JavaDoc style commands (eg. @param) as opposed to the C++ Qt commands (eg. \param). 

Both HTML and Doxygen formatting are possible. For example, a HTML <li>list</li> is often more cumbersome to use than a Doxygen style - List so the latter should used where possible. When preformatted text is required (ie. HTML <pre>) use 

Standard comment tags

Use the following JavaDoc tags 

· @param - (classes, interfaces, methods and constructors only) 

· @return - (methods only) 

· @author - (classes and interfaces only, required) 

· @example - (classes, interfaces, methods and constructors only) 

The description should always be written at the top of the comment. Doxygen will treat an empty new line as a new paragraph. 

Standard comment layout

Only use the following comment layout. 

/**

 * Brief description.

 * Detailed Class, Interface or Method - Description

 *

 * @param <parameter name> <parameter description>

 * @param <parameter name> <parameter description> 

 * @param <parameter name> <parameter description> 

 *

 * @return <return value name> - The return value

 *

 * @example How to use the class, interface or method.

 *

 * @author first author

 * @author second author (etc.)

 */

e.g. a rectangle drawing method commented. 

/**

 * Draw a rectangle.

 * Draw a rectangle of the given colour. Using x, y, 

 * to position. Width and height to size.

 * 

 * @param x - x coordinate for the top left of the rectangle

 * @param y - y coordinate for the top left of the rectangle

 * @param width - width of the rectangle (pixels)

 * @param height - height of the rectangle (pixels)

 * @param color - colour of the rectangle

 * 

 * @example To draw a black rectangle at 0,0 of 100px square use:

 * <pre>

 * Draw.rectangle(0, 0, 100, 100, 0x000000);

 * </pre>

 * 

 * @author jason.milkins

 * @author chris.foster

 */

(note: The first line of the comment block until the . is considered the brief description in JavaDoc, Doxygen requires that JAVADOC_AUTOBRIEF is set to yes for this convention to work.) 

Compiling documentation with Doxygen

With Eclox, Doxygen and Graphviz installed, you will be able to create a Doxygen configuration file for a project. 

Select File > New > Other > Doxyfile to create a Doxygen configuration file. Open a Doxyfile and it is loaded into the Doxyfile editor, this will allow you to see all the options available to Doxygen, there are a lot, select the "By Group" button to sort them into categories. 

You should set the following: 

· Project Name - ...hmmm 

· Project Number - Project version number 

· JavaDoc Autobrief - Yes 

· Optimize Output for Java - Yes 

· Hide Undocumented Classes - No 

· Hide Undocumented Members - No 

· Generate HTML - Yes 

· HTML Output - docs (the path to the HTML output) 

As standard check that other output formats are switched off. (You may want to experiment with the other formats, eg. LaTeX will "easily" convert to PDF.) 

Set the graphing options as you see fit, I recommend that UML style graphs are used (UML Look). Doxygen will take longer to generate graphs if you use the Call Graph = Yes option. 

If you have non-standard JavaDoc tags in your code you should setup Aliases for them too, see here for more info 

Note: As part of the GraphViz installation, the tools required by doxygen, the dot graph builder, will be available on the system path so there should be no need to add the path of dot.exe to the Doxyfile. 

Note: If you enter paths into any of the Doxyfile settings, always make sure that pathnames which contain spaces are quoted. eg. 

\image library\png\

should be... 

"\image library\png"

More information on Doxygen will to follow, in the meantime refer to the Doxygen site 

Please make sure you document your code cleanly

It is important that your code meets these standards, so that your team are able to work with your code as quickly and easily as possible. Adhering to a common standard also means that your code looks the same from week to week and month to month. 

Blogs & Feeds

· MXNA 

· MXNA - Flash 

· MXNA - Flex  

